2013年1月

事情素这个样子:

xcache 3部署在iis6 + php 5.4.x的环境上(废话是fast-cgi模式),在php.ini中设定了
xcache.admin.enable_auth=On
xcache.admin.auth_user = "xxoo"
xcache.admin.pass = "ooxx"
后,访问XCache Administration界面的时候不停的蹦出来要求认证的窗口,不管你密码是不是正确的。

结合前段时间IIRF重写的时候遇到的一个诡异现象(就是重写规则没有命中,明明写对了),判断可能是.Net Framework作祟。
然后看了一下跑XCache Administration的站点的属性,,妥妥的Asp.Net 4.0。在IIS的这个站点的Asp.Net上版本选择成2.x或1.1,然后重启站点就没事儿了。
原因可能是因为Asp.Net 4.0会去修改请求Url之类的东西(比如IIRF那事儿,他会莫名其妙的加一个/eurl.axd******) ,然后这东西干扰了HTTP/1.1 401认证请求或者直接破坏了请求结果,具体为咩回头研究(也就是没空研究的节奏)。

都说PhpStorm比netbeans还是zde靠谱,然后在世界末日那天看到了75%off的折扣果断买了一发,简单玩了一下,好像果然很厉害的样子。
毕竟这货25美刀多呢。
然后发现丫支持VS风格的自定义代码块折叠,但是我最喜欢的Tab缩进在什么地方设置还没有找到,真是忧伤。
貌似还是第一次买ide,聊以纪念,好软件值得付费。 
感谢招商淫行对本次砍手活动提供的大力支持~_~ 

修改editor_config.js:

//Other Code
	//图片在线管理配置区
        , imageManagerUrl: window.UEDITOR_IMAGE_LIST      //图片在线管理的处理地址
        , imageManagerPath: ""           //图片修正地址,同imagePath
//Other Code


修改调用页: 

<script type="text/javascript">
	window.UEDITOR_HOME_URL = "/Content/Editor/";
	window.UEDITOR_IMAGE_LIST = '@Url.Action("GetAttachmentList",
"Article", new{isStandalone=false,articleId=Model.ArticleId})'; </script> <script src="@Url.Content("~/Content/Editor/editor_all_min.js")" type="text/javascript"></script> <script src="@Url.Content("~/Content/Editor/editor_config.js")" type="text/javascript"></script>


喏,妥了。